Vulnerability · Published Jul 27, 2026 · Assigned by GitHub_M
CVE-2026-45623PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments
High 7.5
In plain English
A high-severity path traversal in postcss from postcss. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. In versions 8.5.11 and prior, the PreviousMap parses the /*# sourceMappingURL=PATH */ comment from any CSS string passed to process() and dereferences PATH against the local filesystem with no scheme, allowlist, or traversal check. An attacker who controls the CSS input can cause the host process to read any file readable by Node and leak the first ~10 bytes of its content through the resulting JSON.parse SyntaxError message. The bug also yields a precise file-existence oracle and a controllable-read primitive that may be combined with large-file targets for DoS. The behaviour is triggered with PostCSS's default options — no from, no map, no plugins required — and is therefore reachable from any pipeline that runs untrusted CSS through PostCSS (CMS themes, user-uploaded styles, browser-extension/userstyle processors, build pipelines for third-party packages, blog comment renderers, etc.). This issue has been fixed in version 8.5.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-postcss | no fix listed | DEBIAN-CVE-2026-45623 |
| Debian:13 | node-postcss | no fix listed | DEBIAN-CVE-2026-45623 |
| Debian:14 | node-postcss | 8.5.12+~cs9.3.32-1 | DEBIAN-CVE-2026-45623 |
| Ubuntu:22.04:LTS | node-postcss | no fix listed | UBUNTU-CVE-2026-45623 |
| Ubuntu:24.04:LTS | node-postcss | no fix listed | UBUNTU-CVE-2026-45623 |
| Ubuntu:26.04:LTS | node-postcss | no fix listed | UBUNTU-CVE-2026-45623 |
| Ubuntu:26.10 | node-postcss | no fix listed | UBUNTU-CVE-2026-45623 |
| npm | postcss | 8.5.12 | GHSA-6g55-p6wh-862q |
Affected products (as reported)
Weakness: CWE-22, CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/postcss/postcss/security/advisories/GHSA-6g55-p6wh-862q x_refsource_CONFIRM