Vulnerability · Published May 26, 2026 · Assigned by GitHub_M
CVE-2026-45574epa4all-client: TLS Certificate Validation Disabled in Production
High 8.1
In plain English
A high-severity improper certificate validation in epa4all-client from com.oviva.telematik. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
epa4all-client is the Java Client for epa4all / ePA 3.0 in the Telematik Infrastruktur. Prior to 1.2.2, an attacker on the network path between the ePA service and the Konnektor can present any TLS certificate (self-signed, expired, wrong CN) and intercept all SOAP traffic. This includes patient identifiers (KVNR), SMC-B card operations (authentication, signing), document content, and credential exchanges. This vulnerability is fixed in 1.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.oviva.telematik:epa4all-client | 1.2.2 | GHSA-5hhf-xmfx-4vvr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| oviva-ag | epa4all-client | < 1.2.2 |
| com.oviva.telematik | epa4all-client | < 1.2.2 |
Weakness: CWE-295 · Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/oviva-ag/epa4all-client/security/advisories/GHSA-5hhf-xmfx-4vvr x_refsource_CONFIRM
- https://github.com/oviva-ag/epa4all-client/pull/36 x_refsource_MISC