Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M
CVE-2026-45572Decidim: HTML content blocks allow stored script execution
Medium 4.8
In plain English
A medium-severity code injection in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, an administrator with landing-page editing privileges can store arbitrary HTML and JavaScript in an HTML content block, which Decidim::ContentBlocks::HtmlCell#html_content renders without sanitization, causing the script to execute in visitors' browsers. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | decidim-core | 0.30.9 | GHSA-533c-2vh9-4r86 |
| RubyGems | decidim-core | 0.31.5 | GHSA-533c-2vh9-4r86 |
| RubyGems | decidim-core | 0.32.0 | GHSA-533c-2vh9-4r86 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/decidim/decidim/security/advisories/GHSA-533c-2vh9-4r86 x_refsource_CONFIRM
- https://github.com/decidim/decidim/pull/16451 x_refsource_MISC