Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M

CVE-2026-45415Decidim: CSV census record endpoints improper authorization

Medium 6.0

In plain English

A medium-severity missing authorization in decidim from decidim. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.0Medium
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the /admin/csv_census/census_logs record-management endpoints do not enforce full administrator authorization before rendering or mutating Decidim::Verifications::CsvDatum, allowing a participant manager to create, alter, or remove census records. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-verifications0.30.9GHSA-q79h-67vx-m9xg
RubyGemsdecidim-verifications0.31.5GHSA-q79h-67vx-m9xg
RubyGemsdecidim-verifications0.32.0GHSA-q79h-67vx-m9xg

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.30.9>= 0.31.0.rc1, < 0.31.5>= 0.32.0.rc1, < 0.32.0

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L

References