Vulnerability · Published May 28, 2026 · Assigned by GitHub_M

CVE-2026-45353electerm: Local code through electerm's single-instance socket

Critical 9.3

In plain English

A critical-severity code injection in electerm from electerm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.1%top 98.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From 3.0.6 to 3.8.8, This vulnerability is fixed in 3.9.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmelecterm3.9.0GHSA-7p5m-v798-f8vv

Affected products (as reported)

VendorProductVersions
electerm electerm >= 3.0.6, < 3.89.0

Weakness: CWE-94, CWE-732, CWE-940 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References