Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45304Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")

High 8.7

In plain English

A high-severity security flaw in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.7%top 47.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.53+dfsg-0+deb12u1DEBIAN-CVE-2026-45304
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45304
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45304
Packagistsymfony/symfony7.4.12GHSA-4qpc-3hr4-r2p4
Packagistsymfony/symfony8.0.12GHSA-4qpc-3hr4-r2p4
Packagistsymfony/symfony5.4.52GHSA-4qpc-3hr4-r2p4
Packagistsymfony/symfony6.4.40GHSA-4qpc-3hr4-r2p4
Packagistsymfony/yaml5.4.52GHSA-4qpc-3hr4-r2p4
Packagistsymfony/yaml6.4.40GHSA-4qpc-3hr4-r2p4
Packagistsymfony/yaml7.4.12GHSA-4qpc-3hr4-r2p4
Packagistsymfony/yaml8.0.12GHSA-4qpc-3hr4-r2p4
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45304
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45304
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45304

Affected products (as reported)

VendorProductVersions
symfony symfony < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony yaml < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-776 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References