Vulnerability · Published May 27, 2026 · Assigned by GitHub_M

CVE-2026-45134LangSmith Client SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning

High 7.1

In plain English

A high-severity unsafe deserialization in langsmith-sdk from langchain-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 90.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. Prior to LangSmith SDK Python 0.8.0 and JS/TS 0.6.0, the LangSmith SDK's prompt pull methods (pull_prompt / pull_prompt_commit in Python, pullPrompt / pullPromptCommit in JS/TS) fetch and deserialize prompt manifests from the LangSmith Hub. These manifests may contain serialized LangChain objects and model configuration that affect runtime behavior. When pulling a public prompt by owner/name identifier, the manifest content is controlled by an external party, but prior versions of the SDK did not distinguish this from pulling a prompt within the caller's own organization. This vulnerability is fixed in LangSmith SDK Python 0.8.0 and JS/TS 0.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlangchain0.3.30GHSA-3644-q5cj-c5c7
PyPIlangchain0.3.30PYSEC-2026-2555
PyPIlangchain-classic1.0.7GHSA-3644-q5cj-c5c7
PyPIlangchain-classic1.0.7PYSEC-2026-2560
PyPIlangsmith0.8.0GHSA-3644-q5cj-c5c7
PyPIlangsmith0.8.0PYSEC-2026-2582
npmlangsmith0.6.0GHSA-3644-q5cj-c5c7

Affected products (as reported)

VendorProductVersions
langchain-ai langsmith-sdk < 0.8.0< 0.6.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References