Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M
CVE-2026-45126MyBB: ACP Questions state CSRF
Low 3.5
In plain English
A low-severity cross-site request forgery in mybb from mybb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).
Official description
MyBB is free and open source forum software. Prior to 1.8.40, the Admin CP Security Questions module does not validate the anti-CSRF token correctly, allowing same-site attackers to enable or disable registration challenge questions with a specially crafted URL. The controller processes GET requests for the disable and enable actions to modify mybb_questions.active without verifying the my_post_key token attached by the user interface. The uniquely identifying implementation details include admin/modules/config/questions.php. This issue is fixed in version 1.8.40.
Affected products (as reported)
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/mybb/mybb/security/advisories/GHSA-m42q-vgx3-fqcc x_refsource_CONFIRM
- https://github.com/mybb/mybb/commit/6893b395c7fa3b9e4de6235caea0ce198c376c4f x_refsource_MISC
- https://github.com/mybb/mybb/releases/tag/mybb_1840 x_refsource_MISC
- https://mybb.com/versions/1.8.40 x_refsource_MISC