Vulnerability · Published May 13, 2026 · Assigned by GitHub_M

CVE-2026-45109Next.js: Middleware / Proxy bypass in App Router applications via segment-prefetch routes

High 7.5

In plain English

A high-severity authentication bypass in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 41.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnext15.5.18GHSA-26hh-7cqf-hhc6
npmnext16.2.6GHSA-26hh-7cqf-hhc6

Affected products (as reported)

VendorProductVersions
vercel next.js >= 15.2.0, < 15.5.17>= 16.0.0, < 16.2.6

Weakness: CWE-288, CWE-358 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References