Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45077Symfony: Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener

High 8.3

In plain English

A high-severity unsafe deserialization in monolog-bridge from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.7%top 48.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the server:log listener (Symfony\Bridge\Monolog\Command\ServerLogCommand) binds to 0.0.0.0:9911 by default and processes each received frame with unserialize(base64_decode($message)) without authentication, integrity checks, or an allowed_classes allowlist, allowing any reachable host to submit attacker-chosen serialized PHP payloads that can crash the listener and may trigger object-injection gadget effects. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.53+dfsg-0+deb12u1DEBIAN-CVE-2026-45077
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45077
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45077
Packagistsymfony/monolog-bridge7.4.12GHSA-m7v2-7gxm-vc2v
Packagistsymfony/monolog-bridge8.0.12GHSA-m7v2-7gxm-vc2v
Packagistsymfony/monolog-bridge5.4.52GHSA-m7v2-7gxm-vc2v
Packagistsymfony/monolog-bridge6.4.40GHSA-m7v2-7gxm-vc2v
Packagistsymfony/symfony8.0.12GHSA-m7v2-7gxm-vc2v
Packagistsymfony/symfony6.4.40GHSA-m7v2-7gxm-vc2v
Packagistsymfony/symfony7.4.12GHSA-m7v2-7gxm-vc2v
Packagistsymfony/symfony5.4.52GHSA-m7v2-7gxm-vc2v
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45077
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45077
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45077

Affected products (as reported)

VendorProductVersions
symfony symfony < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony monolog-bridge < 5.4.52>= 6.0.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-502, CWE-668 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

References