Vulnerability · Published May 28, 2026 · Assigned by GitHub_M
CVE-2026-45076Synapse pagination denial of service
Medium 5.1
In plain English
A medium-severity improper input validation in synapse from element-hq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Synapse is an open source Matrix homeserver implementation. Prior to 1.152.1, in federated rooms, malicious homeservers can craft room events in such a way that prevents Synapse from providing full history to paginating clients. Clients could therefore fail to display room history. This vulnerability is fixed in 1.152.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | synapse | 1.152.1-r0 | ALPINE-CVE-2026-45076 |
| Alpine:v3.24 | synapse | 1.152.1-r0 | ALPINE-CVE-2026-45076 |
| Debian:14 | matrix-synapse | 1.152.1-1 | DEBIAN-CVE-2026-45076 |
| PyPI | matrix-synapse | 1.152.1 | GHSA-6qf2-7x63-mm6v |
| PyPI | matrix-synapse | 1.152.1 | PYSEC-2026-194 |
| Ubuntu:24.04:LTS | matrix-synapse | no fix listed | UBUNTU-CVE-2026-45076 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| element-hq | synapse | < 1.152.1 |
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/element-hq/synapse/security/advisories/GHSA-6qf2-7x63-mm6v x_refsource_CONFIRM