Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-45075Symfony: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]
High 8.3
In plain English
A high-severity incorrect authorization in http-kernel from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | symfony | 7.4.12+dfsg-1 | DEBIAN-CVE-2026-45075 |
| Packagist | symfony/http-kernel | 7.4.12 | GHSA-6439-2f28-8p8q |
| Packagist | symfony/http-kernel | 8.0.12 | GHSA-6439-2f28-8p8q |
| Packagist | symfony/security-http | 7.4.12 | GHSA-6439-2f28-8p8q |
| Packagist | symfony/security-http | 8.0.12 | GHSA-6439-2f28-8p8q |
| Packagist | symfony/symfony | 8.0.12 | GHSA-6439-2f28-8p8q |
| Packagist | symfony/symfony | 7.4.12 | GHSA-6439-2f28-8p8q |
| Ubuntu:25.10 | symfony | no fix listed | UBUNTU-CVE-2026-45075 |
| Ubuntu:26.04:LTS | symfony | no fix listed | UBUNTU-CVE-2026-45075 |
| Ubuntu:26.10 | symfony | no fix listed | UBUNTU-CVE-2026-45075 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| symfony | symfony | >= 7.4.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12 |
| symfony | http-kernel | >= 7.4.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12 |
| symfony | security-http | >= 7.4.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/symfony/symfony/security/advisories/GHSA-6439-2f28-8p8q x_refsource_CONFIRM
- https://github.com/symfony/symfony/releases/tag/v7.4.12 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v8.0.12 x_refsource_MISC