Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45072Symfony: Stored XSS in WebProfiler CodeExtension::fileExcerpt() — Unescaped Non-PHP File Rendering

Low 2.0

In plain English

A low-severity cross-site scripting in symfony from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.0Low
Exploit odds (30 days)0.3%top 76.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 6.4.24 until 6.4.40, 7.4.12, and 8.0.12, the development profiler file_excerpt Twig filter escapes PHP files through highlight_string() but interpolates lines from non-PHP files directly into <code> elements, allowing stored XSS against a developer who opens an attacker-written file such as var/log/dev.log in the profiler. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45072
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45072
Packagistsymfony/symfony8.0.12GHSA-hmr5-2xcr-v8pp
Packagistsymfony/symfony7.4.12GHSA-hmr5-2xcr-v8pp
Packagistsymfony/symfony6.4.40GHSA-hmr5-2xcr-v8pp
Packagistsymfony/twig-bridge6.4.40GHSA-hmr5-2xcr-v8pp
Packagistsymfony/web-profiler-bundle8.0.12GHSA-hmr5-2xcr-v8pp
Packagistsymfony/web-profiler-bundle7.4.12GHSA-hmr5-2xcr-v8pp
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45072
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45072
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45072

Affected products (as reported)

VendorProductVersions
symfony symfony >= 6.4.24, < 6.4.40>= 7.2.9, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony twig-bridge >= 6.4.24, < 6.4.40
symfony web-profiler-bundle >= 7.2.9, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References