Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-45069Symfony: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims
High 8.8
In plain English
A high-severity insufficient verification of data authenticity in security-http from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 6.4.40, 7.4.12, and 8.0.12, OidcTokenHandler::verifyClaims() registered audience (aud), issuer (iss), and expiry (exp) checkers but did not pass the mandatory claims list to ClaimCheckerManager::check(), so a validly signed JWT that omitted those claims could pass verification. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | symfony | 6.4.41+dfsg-0+deb13u1 | DEBIAN-CVE-2026-45069 |
| Debian:14 | symfony | 7.4.12+dfsg-1 | DEBIAN-CVE-2026-45069 |
| Packagist | symfony/security-http | 6.4.40 | GHSA-29fc-p6c4-24cg |
| Packagist | symfony/security-http | 7.4.12 | GHSA-29fc-p6c4-24cg |
| Packagist | symfony/security-http | 8.0.12 | GHSA-29fc-p6c4-24cg |
| Packagist | symfony/symfony | 8.0.12 | GHSA-29fc-p6c4-24cg |
| Packagist | symfony/symfony | 6.4.40 | GHSA-29fc-p6c4-24cg |
| Packagist | symfony/symfony | 7.4.12 | GHSA-29fc-p6c4-24cg |
| Ubuntu:25.10 | symfony | no fix listed | UBUNTU-CVE-2026-45069 |
| Ubuntu:26.04:LTS | symfony | no fix listed | UBUNTU-CVE-2026-45069 |
| Ubuntu:26.10 | symfony | no fix listed | UBUNTU-CVE-2026-45069 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| symfony | symfony | >= 6.3.0, < 6.4.40>= 7.4.0, < 7.4.12>= 8.0.0-BETA1, < 8.0.12 |
| symfony | security-http | >= 6.3.0, < 6.4.40>= 7.4.0, < 7.4.12>= 8.0.0-BETA1, < 8.0.12 |
Weakness: CWE-345, CWE-1287 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/symfony/symfony/security/advisories/GHSA-29fc-p6c4-24cg x_refsource_CONFIRM
- https://github.com/symfony/symfony/releases/tag/v6.4.40 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v7.4.12 x_refsource_MISC
- https://github.com/symfony/symfony/releases/tag/v8.0.12 x_refsource_MISC