Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-45064Symfony: HtmlSanitizer URL Attributes Pass Through BiDi Override Characters → Visual href Spoofing

Low 2.3

In plain English

A low-severity security flaw in html-sanitizer from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.3%top 72.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 6.1.0-BETA1 until 6.4.40, 7.4.12, and 8.0.12, UrlSanitizer::parse() passes Unicode explicit-direction BiDi formatting characters through into sanitized href and src attributes, allowing sanitized content to display a link destination that visually differs from the actual destination and enabling phishing-style visual spoofing. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-45064
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-45064
Packagistsymfony/html-sanitizer6.4.40GHSA-h5vq-qfcg-4m6p
Packagistsymfony/html-sanitizer7.4.12GHSA-h5vq-qfcg-4m6p
Packagistsymfony/html-sanitizer8.0.12GHSA-h5vq-qfcg-4m6p
Packagistsymfony/symfony8.0.12GHSA-h5vq-qfcg-4m6p
Packagistsymfony/symfony6.4.40GHSA-h5vq-qfcg-4m6p
Packagistsymfony/symfony7.4.12GHSA-h5vq-qfcg-4m6p
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-45064
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-45064
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-45064

Affected products (as reported)

VendorProductVersions
symfony symfony >= 6.1.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony html-sanitizer >= 6.1.0-BETA1, < 6.4.40>= 7.0.0-BETA1, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-451, CWE-1007 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References