Vulnerability · Published Jul 16, 2026 · Assigned by GitHub_M

CVE-2026-44981CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression

High 8.2

In plain English

A high-severity security flaw in crowdsec from crowdsecurity. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.5%top 56.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/crowdsecurity/crowdsec1.7.8GHSA-273h-gvwr-c3qj
Gogithub.com/crowdsecurity/crowdsec1.7.8GO-2026-5041
Ubuntu:26.10crowdsecno fix listedUBUNTU-CVE-2026-44981

Affected products (as reported)

VendorProductVersions
crowdsecurity crowdsec >= 1.7.0, < 1.7.8

Weakness: CWE-409 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References