Vulnerability · Published Jul 17, 2026 · Assigned by GitHub_M

CVE-2026-44891Netty: Denial of Service via Unbounded Headers in StompSubframeDecoder

High 7.5

In plain English

A high-severity uncontrolled resource consumption in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 45.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.stomp.StompSubframeDecoder fails to limit the total number of headers or their cumulative size per frame, and the maxLineLength parameter only restricts individual header lines. An attacker can send a large number of short headers that are accumulated in memory inside DefaultStompHeadersSubframe until the JVM throws an OutOfMemoryError, causing denial of service for servers exposing a STOMP endpoint based on StompSubframeDecoder. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-44891
Debian:13nettyno fix listedDEBIAN-CVE-2026-44891
Debian:14nettyno fix listedDEBIAN-CVE-2026-44891
Mavenio.netty:netty-codec-stomp4.2.16.FinalGHSA-vhch-2wf3-m8rp
Mavenio.netty:netty-codec-stomp4.1.136.FinalGHSA-vhch-2wf3-m8rp
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-44891

Affected products (as reported)

VendorProductVersions
netty netty < 4.1.136.Final>= 4.2.0.Final, < 4.2.16.Final

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References