Vulnerability · Published May 27, 2026 · Assigned by GitHub_M

CVE-2026-44838RabbitMQ MQTT Topic Permission Authorization Bypass

Medium 5.3

In plain English

A medium-severity incorrect authorization in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities).

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.2%top 89.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 to before 4.2.4, RabbitMQ's MQTT plugin allows for topic-level authorization using regular expressions with variable substitution. Administrators can create patterns such as ^{client_id}-sensors$ to restrict user access to topics that include their client ID. However, the client_id is provided by the user in the MQTT CONNECT packet and is inserted into the regex pattern without escaping special regex characters. This flaw enables an authenticated MQTT user to inject regex operators to bypass authorization. This vulnerability is fixed in 4.2.4 and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-44838
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-44838
Ubuntu:25.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-44838
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-44838

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.4

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:H/SI:H/SA:N

References