Vulnerability · Published May 26, 2026 · Assigned by GitHub_M
CVE-2026-44832Snipe-IT: Privilege Escalation via API Permissions Assignment
High 8.7
In plain English
A high-severity incorrect authorization in snipe-it from grokability. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.4.1, aAn authenticated user with only users.edit permission can escalate their own privileges to admin by sending a PATCH request to /api/v1/users/{id} with permissions[admin]=1. The API controller only strips the superuser key from the permissions array, allowing admin and all other permission keys to be set by any user who can update users. This vulnerability is fixed in 8.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | snipe/snipe-it | 8.4.1 | GHSA-hq28-crg7-95pr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grokability | snipe-it | < 8.4.1 |
Weakness: CWE-281, CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N