Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M
CVE-2026-44795Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
High 8.8
In plain English
A high-severity unsafe deserialization in spinnaker from spinnaker. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3, unsafe YAML processing bypasses safe deserialization when using CloudFormation deployments or CloudFoundry baking. The use of a non-safe constructor allows arbitrary loading of Java classes, leading to remote code execution. This issue is fixed in versions 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | io.spinnaker.orca:orca-core | 2025.3.3 | GHSA-c8q4-9h32-2ww8 |
| Maven | io.spinnaker.orca:orca-core | 2025.4.4 | GHSA-c8q4-9h32-2ww8 |
| Maven | io.spinnaker.orca:orca-core | 2026.0.3 | GHSA-c8q4-9h32-2ww8 |
| Maven | io.spinnaker.rosco:rosco-core | 2025.3.3 | GHSA-c8q4-9h32-2ww8 |
| Maven | io.spinnaker.rosco:rosco-core | 2025.4.4 | GHSA-c8q4-9h32-2ww8 |
| Maven | io.spinnaker.rosco:rosco-core | 2026.0.3 | GHSA-c8q4-9h32-2ww8 |
Affected products (as reported)
Weakness: CWE-470, CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-c8q4-9h32-2ww8 x_refsource_CONFIRM
- https://github.com/spinnaker/spinnaker/commit/4cbe1d5fea9df573aadfd8b093fb4b594b354ee5 x_refsource_MISC
- https://github.com/spinnaker/spinnaker/commit/e57c0db4584b398473a7bbb19402ce6c1e89b627 x_refsource_MISC
- https://github.com/spinnaker/spinnaker/commit/f69d7b534d068ed74d0d3a1fbf17e2c945d36e5e x_refsource_MISC