Vulnerability · Published Jun 26, 2026 · Assigned by GitHub_M
CVE-2026-44733OpenProject: Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements
Medium 5.9
In plain English
A medium-severity security flaw in openproject from opf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).
Official description
OpenProject is open-source, web-based project management software. Prior to 17.3.2 and 17.4.0, Business Logic Error on OpenProject through PATCH request to /api/v3/users/me permits to bypass password requirements. A password validation flaw in the change password behavior allows attackers to change a user's password only with an active session takeover. This vulnerability is fixed in 17.3.2 and 17.4.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| opf | openproject | < 17.3.2 |
Weakness: CWE-620 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
References
- https://github.com/opf/openproject/security/advisories/GHSA-px7f-cj9f-7m4m x_refsource_CONFIRM