Vulnerability · Published May 26, 2026 · Assigned by GitHub_M
CVE-2026-44728Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs
High 8.2
In plain English
A high-severity code injection in babel from babel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.1%top 97.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-babel7 | no fix listed | DEBIAN-CVE-2026-44728 |
| Debian:13 | node-babel7 | no fix listed | DEBIAN-CVE-2026-44728 |
| Debian:14 | node-babel7 | 8.0.4+ds1+~cs177.303.116-2 | DEBIAN-CVE-2026-44728 |
| Ubuntu:22.04:LTS | node-babel7 | no fix listed | UBUNTU-CVE-2026-44728 |
| Ubuntu:24.04:LTS | node-babel7 | no fix listed | UBUNTU-CVE-2026-44728 |
| Ubuntu:25.10 | node-babel7 | no fix listed | UBUNTU-CVE-2026-44728 |
| Ubuntu:26.04:LTS | node-babel7 | no fix listed | UBUNTU-CVE-2026-44728 |
| Ubuntu:26.10 | node-babel7 | no fix listed | UBUNTU-CVE-2026-44728 |
| npm | @babel/plugin-transform-modules-systemjs | 8.0.0-alpha.13 | GHSA-fv7c-fp4j-7gwp |
| npm | @babel/plugin-transform-modules-systemjs | 7.29.4 | GHSA-fv7c-fp4j-7gwp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| babel | babel | >= 7.12.0, < 7.29.4>= 8.0.0-alpha.0, < 8.0.0-alpha.13 |
| @babel | plugin-transform-modules-systemjs | >= 7.12.0, < 7.29.4>= 8.0.0-alpha.0, < 8.0.0-alpha.13 |
Weakness: CWE-94, CWE-843 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/babel/babel/security/advisories/GHSA-fv7c-fp4j-7gwp x_refsource_CONFIRM