Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-44727Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP

Critical 9.0

In plain English

A critical-severity cross-site scripting in jupyter_server from jupyter-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.0Critical
Exploit odds (30 days)0.4%top 61.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Server is the backend for Jupyter web applications. Prior to 2.20, the nbconvert HTTP handlers in jupyter_server render user-authored notebook HTML under the Jupyter origin without a sandbox directive in their Content-Security-Policy. Combined with nbconvert.HTMLExporter's default non-sanitizing behavior, a notebook carrying an HTML payload in a display_data output triggers stored XSS with cookie access, full /api/* authority, and kernel RCE. This vulnerability is fixed in 2.20.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jupyter-serverno fix listedDEBIAN-CVE-2026-44727
Debian:13jupyter-serverno fix listedDEBIAN-CVE-2026-44727
Debian:14jupyter-server2.20.0-1DEBIAN-CVE-2026-44727
PyPIjupyter-server2.20.0GHSA-fcw5-x6j4-ccmp
PyPIjupyter-server2.20.0PYSEC-2026-366
Ubuntu:22.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-44727
Ubuntu:24.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-44727
Ubuntu:25.10jupyter-serverno fix listedUBUNTU-CVE-2026-44727
Ubuntu:26.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-44727
Ubuntu:26.10jupyter-serverno fix listedUBUNTU-CVE-2026-44727

Affected products (as reported)

VendorProductVersions
jupyter-server jupyter_server < 2.20

Weakness: CWE-79, CWE-1021 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References