Vulnerability · Published May 14, 2026 · Assigned by GitHub_M

CVE-2026-44662rust-openssl: Heap buffer overflow when encrypting with AES key-wrap-with-padding

Medium 5.1

In plain English

A medium-severity heap buffer overflow in rust-openssl from rust-openssl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.2%top 93.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.10.0 to before 0.10.79, CipherCtxRef::cipher_update, CipherCtxRef::cipher_update_vec, and symm::Crypter::update incorrectly sized output buffers when used with AES key-wrap-with-padding ciphers (EVP_aes_{128,192,256}_wrap_pad). For a non-multiple-of-8 input, OpenSSL writes up to 7 bytes past the end of the caller's buffer or Vec, producing attacker-controllable heap corruption when the plaintext length is attacker-influenced. This only impacts users using AES key-wrap-with-padding ciphers. This vulnerability is fixed in 0.10.79.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rust-opensslno fix listedDEBIAN-CVE-2026-44662
Debian:13rust-opensslno fix listedDEBIAN-CVE-2026-44662
Debian:14rust-openssl0.10.79-1DEBIAN-CVE-2026-44662
Ubuntu:25.10rust-opensslno fix listedUBUNTU-CVE-2026-44662
Ubuntu:26.04:LTSrust-opensslno fix listedUBUNTU-CVE-2026-44662
Ubuntu:26.10rust-opensslno fix listedUBUNTU-CVE-2026-44662

Affected products (as reported)

VendorProductVersions
rust-openssl rust-openssl >= 0.10.0, < 0.10.79

Weakness: CWE-122 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References