Vulnerability · Published May 29, 2026 · Assigned by GitHub_M
CVE-2026-44651SillyTavern: Reflected XSS vulnerability in the CORS proxy middleware
Medium 6.9
In plain English
A medium-severity cross-site scripting in SillyTavern from SillyTavern. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, when fetch(url) throws, the code sends: res.status(500).send('Error occurred while trying to proxy to: ' + url + ' ' + error). The url value is attacker-controlled (req.params.url) and is not HTML-escaped before rendering. This vulnerability is fixed in 1.18.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | sillytavern | 1.18.0 | GHSA-xc4x-2452-5gc9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| SillyTavern | SillyTavern | < 1.18.0 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N