Vulnerability · Published May 29, 2026 · Assigned by GitHub_M

CVE-2026-44648SillyTavern: Existing sessions are not invalidated after password change, allowing session reuse and account takeover

High 7.5

In plain English

A high-severity security flaw in SillyTavern from SillyTavern. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 66.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, SillyTavern relies on cookie-session for authentication, storing all session data (user handle, permissions) in a signed cookie. The endpoints POST /api/users/change-password and POST /api/users/recover-step2 only update the password hash in the database but do not expire current sessions. Because the session is stateless and stored entirely in the client cookie, there is no server-side mechanism to revoke a token once issued. This vulnerability is fixed in 1.18.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmsillytavern1.18.0GHSA-wmm3-h9qj-p5v6

Affected products (as reported)

VendorProductVersions
SillyTavern SillyTavern < 1.18.0

Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References