Vulnerability · Published Jul 16, 2026 · Assigned by GitHub_M

CVE-2026-44595Yamcs: Unauthorized user enumeration via IAM API endpoints

Medium 4.3

In plain English

A medium-severity missing authorization in yamcs from yamcs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)1.1%top 35.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Yamcs is a mission control framework. Prior to 5.12.7, the IAM API endpoints listUsers, getUser, listGroups, and getGroup in yamcs-core did not enforce the required SystemPrivilege.ControlAccess check in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java, so any authenticated user, even one with low or no privileges, could enumerate all user accounts in the system including their usernames, superuser status, and group memberships. This issue is fixed in versions 5.12.7 and 5.13.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.yamcs:yamcs-core5.12.7GHSA-p2rj-mrmc-9w29

Affected products (as reported)

VendorProductVersions
yamcs yamcs < 5.12.7

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References