Vulnerability · Published May 13, 2026 · Assigned by GitHub_M

CVE-2026-44574Next.js: Middleware / Proxy bypass through dynamic route parameter injection

High 8.1

In plain English

A high-severity authentication bypass in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.6%top 49.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnext15.5.16GHSA-492v-c6pp-mqqv
npmnext16.2.5GHSA-492v-c6pp-mqqv

Affected products (as reported)

VendorProductVersions
vercel next.js >= 15.4.0, < 15.5.16>= 16.0.0, < 16.2.5

Weakness: CWE-288, CWE-551 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References