Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-44363Unsafe remote resource fetching in expansion misp-modules
Medium 5.8
In plain English
A medium-severity improper certificate validation in misp-modules from MISP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
MISP modules are autonomous modules that can be used to extend MISP for new services. Prior to 3.0.7, an unsafe remote resource fetching vulnerability existed in MISP Modules expansion modules. The html_to_markdown module accepted arbitrary HTTP(S) URLs without sufficient validation, which could allow Server-Side Request Forgery against loopback, private, or link-local network resources. Additionally, the qrcode module disabled TLS certificate verification when retrieving remote images, exposing requests to potential man-in-the-middle interception or response tampering. The issue was fixed by validating URL schemes, blocking local and private address ranges, resolving hostnames before fetching, enforcing request timeouts, and re-enabling TLS certificate verification. This vulnerability is fixed in 3.0.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | misp-modules | 3.0.8 | GHSA-fhq3-2gf3-8f3j |
| PyPI | misp-modules | no fix listed | PYSEC-2026-2650 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| MISP | misp-modules | < 3.0.7 |
Weakness: CWE-295, CWE-918 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H