Vulnerability · Published May 14, 2026 · Assigned by GitHub_M

CVE-2026-44312css_parser allows to MITM included https css urls

Medium 5.8

In plain English

A medium-severity improper certificate validation in css_parser from premailer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)0.1%top 96.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-css-parser1.6.0-2+deb12u1DEBIAN-CVE-2026-44312
Debian:13ruby-css-parser1.19.0-1+deb13u1DEBIAN-CVE-2026-44312
Debian:14ruby-css-parser2.1.0-1DEBIAN-CVE-2026-44312
RubyGemscss_parser2.1.0GHSA-ff6c-w6qf-7xqc
RubyGemscss_parser1.22.0GHSA-ff6c-w6qf-7xqc
Ubuntu:22.04:LTSruby-css-parserno fix listedUBUNTU-CVE-2026-44312
Ubuntu:24.04:LTSruby-css-parserno fix listedUBUNTU-CVE-2026-44312
Ubuntu:25.10ruby-css-parserno fix listedUBUNTU-CVE-2026-44312
Ubuntu:26.04:LTSruby-css-parserno fix listedUBUNTU-CVE-2026-44312
Ubuntu:26.10ruby-css-parserno fix listedUBUNTU-CVE-2026-44312

Affected products (as reported)

VendorProductVersions
premailer css_parser >= 2.0.0, < 2.1.0< 1.22.0

Weakness: CWE-829, CWE-295 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

References