Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M

CVE-2026-44282Election question titles allow stored script execution

Medium 4.8

In plain English

A medium-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.4%top 66.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. Prior to 0.32.0, a low-privilege process-scoped administrator or election editor with question-management rights can store HTML or script-bearing content in question.body. The question_title helper returns the translatable question body through html_safe without a sanitization boundary, causing stored script execution when visitors open public election pages or voting booth screens. The persisted script executes in visitors' browsers. The vulnerability is fixed in 0.32.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-elections0.32.0GHSA-9mvp-w4rr-5c6x

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.32.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

References