Vulnerability · Published May 7, 2026 · Assigned by GitHub_M

CVE-2026-44264Weblate is vulnerable to XSS via crafted Markdown

Medium 4.3

In plain English

A medium-severity security flaw in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.3%top 80.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Weblate is a web based localization tool. Prior to version 5.17.1, the Markdown renderer used in user comments and other user-provided content didn't properly sanitize some attributes. This issue has been patched in version 5.17.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIweblate5.17.1GHSA-5cmv-3rc4-7279
PyPIweblate5.17.1PYSEC-2026-2319

Affected products (as reported)

VendorProductVersions
WeblateOrg weblate < 5.17.1

Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References