Vulnerability · Published May 12, 2026 · Assigned by GitHub_M

CVE-2026-44240basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering

High 7.5

In plain English

A high-severity uncontrolled resource consumption in basic-ftp from patrickjuchli. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

basic-ftp is an FTP client for Node.js. Prior to 5.3.1, basic-ftp is vulnerable to client-side denial of service when parsing FTP control-channel multiline responses. A malicious or compromised FTP server can send an unterminated multiline response during the initial FTP banner phase, before authentication. The client keeps appending attacker-controlled data into FtpContext._partialResponse and repeatedly reparses the accumulated buffer without enforcing a maximum control response size. As a result, an application using basic-ftp can remain stuck in connect() while memory and CPU usage grow under attacker-controlled input. This can lead to process-level denial of service, container OOM kills, worker restarts, queue backlog, or service degradation in applications that automatically connect to FTP endpoints. This vulnerability is fixed in 5.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-proxy-agentsno fix listedDEBIAN-CVE-2026-44240
Debian:14node-proxy-agents0~2025070717+~cs15.3.8-1DEBIAN-CVE-2026-44240
Ubuntu:24.04:LTSnode-proxy-agentsno fix listedUBUNTU-CVE-2026-44240
Ubuntu:25.10node-proxy-agentsno fix listedUBUNTU-CVE-2026-44240
Ubuntu:26.04:LTSnode-proxy-agentsno fix listedUBUNTU-CVE-2026-44240
Ubuntu:26.10node-proxy-agentsno fix listedUBUNTU-CVE-2026-44240
npmbasic-ftp5.3.1GHSA-rpmf-866q-6p89

Affected products (as reported)

VendorProductVersions
patrickjuchli basic-ftp < 5.3.1

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References