Vulnerability · Published Sep 17, 2026 · Assigned by GitHub_M

CVE-2026-44236rabbitmq-c: Heap buffer overflow in AMQP login handshake via undersized connection.tune.frame_max

High 7.1

In plain English

A high-severity heap buffer overflow in rabbitmq-c from alanxz. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.4%top 65.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized connection.tune.frame_max value during amqp_login(), and rabbitmq-c accepts the value in amqp_login_inner() in librabbitmq/amqp_socket.c. amqp_tune_connection() in librabbitmq/amqp_connection.c uses frame_max to reallocate the outbound buffer without enforcing AMQP_FRAME_MIN_SIZE. Immediate serialization of connection.tune-ok through amqp_frame_to_bytes() writes beyond the undersized heap allocation, causing memory corruption and likely denial of service. An on-path attacker can also trigger the flaw against plaintext AMQP traffic. Code execution is theoretically possible but was not demonstrated. This issue is fixed in version 0.16.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10librabbitmq0.14.0-3.el10_2.1ALSA-2026:84795
AlmaLinux:9librabbitmq0.11.0-7.el9_8.1ALSA-2026:82094
AlmaLinux:10librabbitmq-devel0.14.0-3.el10_2.1ALSA-2026:84795
AlmaLinux:8librabbitmq-devel0.9.0-6.el8_10ALSA-2026:75582
AlmaLinux:9librabbitmq-devel0.11.0-7.el9_8.1ALSA-2026:82094
AlmaLinux:10librabbitmq-tools0.14.0-3.el10_2.1ALSA-2026:84795
AlmaLinux:9librabbitmq-tools0.11.0-7.el9_8.1ALSA-2026:82094
Debian:12librabbitmq0.11.0-1+deb12u2DEBIAN-CVE-2026-44236
Debian:13librabbitmq0.15.0-1+deb13u1DEBIAN-CVE-2026-44236
Debian:14librabbitmq0.16.0-1DEBIAN-CVE-2026-44236
Rocky Linux:10librabbitmq0:0.14.0-3.el10_2.1RLSA-2026:84795
Rocky Linux:8librabbitmq0:0.9.0-6.el8_10RLSA-2026:75582
Rocky Linux:9librabbitmq0:0.11.0-7.el9_8.1RLSA-2026:82094
Ubuntu:22.04:LTSlibrabbitmq0.10.0-1ubuntu2.2USN-8724-1
Ubuntu:22.04:LTSlibrabbitmq0.10.0-1ubuntu2.1USN-8437-1
Ubuntu:22.04:LTSlibrabbitmq0.10.0-1ubuntu2.1UBUNTU-CVE-2026-44236
Ubuntu:24.04:LTSlibrabbitmq0.11.0-1ubuntu0.1USN-8437-1
Ubuntu:24.04:LTSlibrabbitmq0.11.0-1ubuntu0.1UBUNTU-CVE-2026-44236
Ubuntu:24.04:LTSlibrabbitmq0.11.0-1ubuntu0.2USN-8724-1
Ubuntu:25.10librabbitmq0.15.0-1ubuntu0.25.10.1USN-8437-1
Ubuntu:25.10librabbitmq0.15.0-1ubuntu0.25.10.1UBUNTU-CVE-2026-44236
Ubuntu:26.04:LTSlibrabbitmq0.15.0-1ubuntu0.26.04.1USN-8437-1
Ubuntu:26.04:LTSlibrabbitmq0.15.0-1ubuntu0.26.04.1UBUNTU-CVE-2026-44236
Ubuntu:26.04:LTSlibrabbitmq0.15.0-1ubuntu0.26.04.2USN-8724-1

Affected products (as reported)

VendorProductVersions
alanxz rabbitmq-c < 0.16.0

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

References