Vulnerability · Published Jul 20, 2026 · Assigned by GitHub_M
CVE-2026-44228RT: Stored Cross-Site Scripting via insufficient template escaping
Medium 5.4
In plain English
A medium-severity cross-site scripting in rt from bestpractical. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities).
Official description
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:26.10 | request-tracker5 | no fix listed | UBUNTU-CVE-2026-44228 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| bestpractical | rt | >= 6.0.0, < 6.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/bestpractical/rt/security/advisories/GHSA-pfgp-5j8g-phgc x_refsource_CONFIRM
- https://github.com/bestpractical/rt/releases/tag/rt-6.0.3 x_refsource_MISC