Vulnerability · Published Jul 20, 2026 · Assigned by GitHub_M

CVE-2026-44227RT: Reflected Cross-Site Scripting via URL parameters

Medium 6.1

In plain English

A medium-severity cross-site scripting in rt from bestpractical. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 81.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3 contain a reflected Cross-Site Scripting (XSS) vulnerability. An attacker who can induce an authenticated RT user to visit a crafted URL can execute arbitrary JavaScript in that user's browser session. There are no effective workarounds. Avoid following untrusted RT URLs. This issue has been fixed in version 6.0.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12request-tracker4no fix listedDEBIAN-CVE-2026-44227
Debian:12request-tracker5no fix listedDEBIAN-CVE-2026-44227
Debian:13request-tracker5no fix listedDEBIAN-CVE-2026-44227
Debian:14request-tracker55.0.10+dfsg-1DEBIAN-CVE-2026-44227
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-44227
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-44227
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2026-44227
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2026-44227
Ubuntu:25.10request-tracker5no fix listedUBUNTU-CVE-2026-44227
Ubuntu:26.10request-tracker5no fix listedUBUNTU-CVE-2026-44227

Affected products (as reported)

VendorProductVersions
bestpractical rt >= 6.0.0, < 6.0.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References