Vulnerability · Published May 12, 2026 · Assigned by GitHub_M
CVE-2026-44222vLLM: Remote DoS via Special-Token Placeholders
Medium 6.5
In plain English
A medium-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From 0.6.1 to before 0.20.0, there is a a Token Injection vulnerability in vLLM’s multimodal processing. Unauthenticated, text-only prompts that spell special tokens are interpreted as control. Image and video placeholder sequences supplied without matching data cause vLLM to index into empty grids during input-position computation, raising an unhandled IndexError and terminating the worker or degrading availability. Multimodal paths that rely on image_grid_thw/video_grid_thw are affected. This vulnerability is fixed in 0.20.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vllm | 0.20.0 | GHSA-hpv8-x276-m59f |
| PyPI | vllm | 0.20.0 | PYSEC-2026-3409 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | >= 0.6.1, < 0.20.0 |
Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-hpv8-x276-m59f x_refsource_CONFIRM
- https://github.com/vllm-project/vllm/issues/32656 x_refsource_MISC