Vulnerability · Published May 14, 2026 · Assigned by GitHub_M
CVE-2026-44212PrestaShop: Stored XSS executable in customer service view
Critical 9.3
In plain English
A critical-severity cross-site scripting in PrestaShop from PrestaShop. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | prestashop/prestashop | 8.2.6 | GHSA-w9f3-qc75-qgx9 |
| Packagist | prestashop/prestashop | 9.1.1 | GHSA-w9f3-qc75-qgx9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PrestaShop | PrestaShop | < 8.2.6>= 9.0.0-alpha.1, < 9.1.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-w9f3-qc75-qgx9 x_refsource_CONFIRM