Vulnerability · Published May 11, 2026 · Assigned by GitHub_M
CVE-2026-44201Wagtail: Improper restriction handling on Documents and Images API
Medium 5.3
In plain English
A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. Prior to 7.0.7, 7.3.2, and 7.4, the Documents and Images API incorrectly listed items in private collections. A user with access to the API could see the filename and name of documents and images in private collections. This vulnerability is fixed in 7.0.7, 7.3.2, and 7.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.0.7 | GHSA-p5gm-92h4-6pv6 |
| PyPI | wagtail | 7.3.2 | GHSA-p5gm-92h4-6pv6 |
| PyPI | wagtail | 7.0.7, 7.3.2 | PYSEC-2026-150 |
Affected products (as reported)
Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-p5gm-92h4-6pv6 x_refsource_CONFIRM