Vulnerability · Published May 11, 2026 · Assigned by GitHub_M
CVE-2026-44198Wagtail: Improper permission handling when viewing page history
Medium 4.3
In plain English
A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. Prior to 7.0.7, 7.3.2, and 7.4, a CMS user without the ability to edit a page could still access the history report for the page, potentially resulting in disclosure of sensitive information. This vulnerability is fixed in 7.0.7, 7.3.2, and 7.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.0.7 | GHSA-c4mr-889m-vgf6 |
| PyPI | wagtail | 7.3.2 | GHSA-c4mr-889m-vgf6 |
| PyPI | wagtail | 7.0.7, 7.3.2 | PYSEC-2026-147 |
Affected products (as reported)
Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-c4mr-889m-vgf6 x_refsource_CONFIRM