Vulnerability · Published May 11, 2026 · Assigned by GitHub_M
CVE-2026-44197Wagtail: Improper permission handling when comparing revisions
Medium 6.5
In plain English
A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. Prior to 7.0.7, 7.3.2, and 7.4, a CMS user without the ability to edit a page could access revisions of the page through the revision compare view if they knew the primary key of two revisions. This could potentially result in disclosure of sensitive information. This vulnerability is fixed in 7.0.7, 7.3.2, and 7.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.0.7 | GHSA-c6wj-9vcj-75pj |
| PyPI | wagtail | 7.3.2 | GHSA-c6wj-9vcj-75pj |
| PyPI | wagtail | 7.0.7, 7.3.2 | PYSEC-2026-146 |
Affected products (as reported)
Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-c6wj-9vcj-75pj x_refsource_CONFIRM