Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-44194OPNsense: RCE on user managment
Critical 9.1
In plain English
A critical-severity OS command injection in core from opnsense. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 5.7% (higher than 93% of all known vulnerabilities).
Official description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 x_refsource_CONFIRM