Vulnerability · Published Jun 8, 2026 · Assigned by apache

CVE-2026-44185Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`

High 7.3

In plain English

A high-severity out-of-bounds read in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.7%top 45.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10httpd2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9httpd2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-core2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-core2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-devel2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9httpd-devel2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-filesystem2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-filesystem2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-manual2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9httpd-manual2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-tools2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9httpd-tools2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+4233+8b7d9181.7ALSA-2026:42828
AlmaLinux:10mod_ldap2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9mod_ldap2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_lua2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_lua2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:8mod_md1:2.0.8-8.module_el8.10.0+4088+57f011c1.2ALSA-2026:42828
AlmaLinux:10mod_proxy_html1:2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9mod_proxy_html1:2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_session2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9mod_session2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_ssl1:2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+4233+8b7d9181.9ALSA-2026:42828
AlmaLinux:9mod_ssl1:2.4.62-13.el9_8.5ALSA-2026:41906
Alpine:v3.21apache22.4.68-r0ALPINE-CVE-2026-44185
Alpine:v3.22apache22.4.68-r0ALPINE-CVE-2026-44185
Alpine:v3.23apache22.4.68-r0ALPINE-CVE-2026-44185
Alpine:v3.24apache22.4.68-r0ALPINE-CVE-2026-44185
Debian:12apache22.4.68-1~deb12u1DEBIAN-CVE-2026-44185
Debian:13apache22.4.68-1~deb13u1DEBIAN-CVE-2026-44185
Debian:14apache22.4.68-1DEBIAN-CVE-2026-44185
Rocky Linux:10httpd0:2.4.63-13.el10_2.4RLSA-2026:34109
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+2061+8d03fdec.5RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1984+1bed3124.4RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40045+6ce8579b.6RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40206+be2c8a50.8RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40053+5a18018e.7RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2026:42828
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40197+0231e209.8RLSA-2026:42828
Rocky Linux:9httpd0:2.4.62-13.el9_8.5RLSA-2026:41906
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+2061+8d03fdec.4RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+40197+0231e209.5RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2026:42828
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+40204+716978aa.6RLSA-2026:42828
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2026:42828
Rocky Linux:8mod_md1:2.0.8-8.module+el8.10.0+40053+5a18018e.2RLSA-2026:42828
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.23USN-8516-1
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.23UBUNTU-CVE-2026-44185
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.15UBUNTU-CVE-2026-44185
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.15USN-8516-1
Ubuntu:25.10apache2no fix listedUBUNTU-CVE-2026-44185
Ubuntu:26.04:LTSapache22.4.66-2ubuntu2.4USN-8516-1
Ubuntu:26.04:LTSapache22.4.66-2ubuntu2.4UBUNTU-CVE-2026-44185

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.0 – through 2.4.67

Weakness: CWE-126, CWE-125 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References