Vulnerability · Published Jul 16, 2026 · Assigned by GitHub_M

CVE-2026-44175Kirby: Cross-site scripting (XSS) from list field content in the site frontend

High 8.5

In plain English

A high-severity cross-site scripting in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.4%top 62.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, Kirby did not securely sanitize the contents of the list field on save, leaving it vulnerable to cross-site scripting (XSS). Kirby's list field stores its formatted content as HTML, and unlike other field types, its HTML special characters cannot be escaped without losing the formatting. Sanitization was only enforced client-side in the Panel, while the server did not sanitize the content on save. As a result, an attacker could bypass the Panel and send malicious HTML directly to Kirby's API, storing unsanitized markup in the content file. That markup would then be rendered on the site frontend and executed in the browsers of site visitors and logged-in users browsing the site, resulting in persistent XSS. This issue has been fixed in versions 4.9.1 and 5.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms4.9.1GHSA-5fhx-9q32-q257
Packagistgetkirby/cms5.4.1GHSA-5fhx-9q32-q257

Affected products (as reported)

VendorProductVersions
getkirby kirby < 4.9.1>= 5.0.0, < 5.4.1

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References