Vulnerability · Published Jul 16, 2026 · Assigned by GitHub_M

CVE-2026-44174Kirby: Arbitrary Method Call via REST API search and collection query endpoints

High 8.7

In plain English

A high-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 57.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is an open-source content management system. Prior to 4.9.1 and 5.4.1, Kirby did not validate the model attributes that were used in its collection queries, allowing attackers to include arbitrary model methods in their queries. This includes methods with sensitive data such as password() (disclosing the password hash) or root() (disclosing the absolute filesystem path on the server) as well as methods that perform impactful actions such as loginPasswordless() (causing a privilege escalation to another user) or delete() (deleting all queried models in one go if the authenticated user has appropriate permissions). This issue has been fixed in versions 4.9.1 and 5.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms4.9.1GHSA-86rh-h242-j8xp
Packagistgetkirby/cms5.4.1GHSA-86rh-h242-j8xp

Affected products (as reported)

VendorProductVersions
getkirby kirby < 4.9.1>= 5.0.0, < 5.4.1

Weakness: CWE-470 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References