Vulnerability · Published Sep 14, 2026 · Assigned by GitHub_M
CVE-2026-44162fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`
Low 2.7
In plain English
A low-severity security flaw in fluent-plugin-s3 from fluent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | fluent-plugin-s3 | 1.8.5 | GHSA-xv9w-7v6q-hpjh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| fluent | fluent-plugin-s3 | >= 0.7.0, < 1.8.5 |
Weakness: CWE-409 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L