Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-44161Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`

High 7.2

In plain English

A high-severity server-side request forgery in fluentd from fluent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.2High
Exploit odds (30 days)0.4%top 61.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsfluentd1.19.3GHSA-72f5-rr8c-r6gr

Affected products (as reported)

VendorProductVersions
fluent fluentd < 1.19.3

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L

References