Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-44025Fluentd: Exposure of Sensitive Information via Monitor Agent API

High 7.5

In plain English

A high-severity missing authentication in fluentd from fluent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 58.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsfluentd1.19.3GHSA-pr7j-96cj-549h

Affected products (as reported)

VendorProductVersions
fluent fluentd < 1.19.3

Weakness: CWE-306 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References