Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-44024Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder

Critical 9.8

In plain English

A critical-severity path traversal in fluentd from fluent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)1.1%top 34.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsfluentd1.19.3GHSA-44hj-4m45-frj3

Affected products (as reported)

VendorProductVersions
fluent fluentd < 1.19.3

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References