Vulnerability · Published Jun 24, 2026 · Assigned by GitHub_M

CVE-2026-44016Docling: Unsafe Playwright-based HTML Rendering

High 8.2

In plain English

A high-severity code injection in docling from docling-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.6%top 51.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. FIn versions >= 2.82.0, < 2.91.0, if the HTML backend was explicitly configured for rendering (rendering option by default deactivated), then the Playwright-based rendering feature could allow JavaScript execution and unrestricted network access when processing untrusted HTML documents. An attacker could craft malicious HTML that executes arbitrary JavaScript in the rendering context or makes unauthorized network requests to internal services, potentially leading to SSRF attacks, data exfiltration, or remote code execution in the rendering environment. This vulnerability is fixed in 2.91.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIdocling2.91.0GHSA-pj2v-ggqh-cmq2
PyPIdocling2.91.0PYSEC-2026-2142

Affected products (as reported)

VendorProductVersions
docling-project docling >= 2.82.0, < 2.91.0

Weakness: CWE-94, CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L

References